Thursday Jun 07

Links

Books

User Menu

AddThis

AddThis Social Bookmark Button

Eclipse WTP Troubleshooting

PDF Print E-mail
Monday, 09 May 2011 07:35
AddThis Social Bookmark Button

Eclipse WTP Error handling Eclipse WTP Troubleshooting

Java compiler level does not match the version of the installed Java project facet Java compiler level does not match the version of the installed Java project facet

A wtp project is composed of multiple units of functionality (known as facets). Take a look at Project Properties -> Project Facets panel.

The java facet version needs to always match the java compiler compliance level. The best way to change java level is to use the Project Facets properties panel as that will update both places at the same time. Alternatively, when you get the error that you are referring to, there are quick fixes available to resolve it.

There are no resources that can be added or removed from the server There are no resources that can be added or removed from the server

Solution no resources that can be added or removed You need to have an Eclipse Dynamic Web Module facet . You can try doing this via the project properties dialog and looking at project facets, then clicking the appropriate check box. This may not be avaliable however, so you may need to do the next thing.

Keep in mind, once you add those facets, you cannot change them back via Eclipse .

N.B : If you already have the project facets options avaliable but can't add the web module, go down to the check box area on the Facets choice and right click. A dialog menu with the phrase "unlock" will come up, allowing you to add the Dynamic Web Project Facet to the project

Tags: java , eclipse , project , properties , facets , facet , check

Add comment


Security code
Refresh